Discussion:
reparar windows installer en xp
(demasiado antiguo para responder)
sylvia
2004-02-23 18:07:55 UTC
hola, tengo un equipo con SO XP professional, quiero
instalar un antivirus, pero no me deja porque me marca un
error en el windows installer...este error dice que
windows installer no esta bien instalado.
que puedo hacer para que me deje instalar el antivirus???

PD. le hice un update a mi SO y el problema persiste.
El antivirus lo he instalado en varios equipos con XP y
es la primera vez que me pasa esto.

Gracias por su ayuda
Alezito [MS MVP]
2004-02-23 18:18:09 UTC
Comprueba que:

Panel de Control - Herramientas Administrativas - Servicios

que el servicio "Windows Installer" esta en Inicio "Manual".

Arranca en "modo seguro" (tecla F8 en el reinicio) y teclea desde:

Inicio - Ejecutar: msiexec /regserver

Reinicia el sistema.
--
Alejandro Curquejo
Microsoft MVP
Windows XP - Shell/User
***@mvps.org
---------------------------------------------------------------------
*Este mensaje se proporciona "TAL COMO ESTA" sin garantia de ninguna clase y
no otorga ningun derecho de reclamo*
*This posting is provided "AS IS" with no warranties, and confers no rights*
---------------------------------------------------------------------
-Tips y Articulos XP - http://www.multingles.net/tutoriales.htm#ALE
-DTS-L.Org - http://www.dts-l.org/
---------------------------------------------------------------------
Que es el Programa MVP (Most Valuable Professional)
http://mvp.support.microsoft.com/default.aspx?pr=mvpfaqs
---------------------------------------------------------------------


"sylvia" <***@discussions.microsoft.com> escribi� en el mensaje news:1521b01c3fa37$f5d57c20$***@phx.gbl...
| hola, tengo un equipo con SO XP professional, quiero
| instalar un antivirus, pero no me deja porque me marca un
| error en el windows installer...este error dice que
| windows installer no esta bien instalado.
| que puedo hacer para que me deje instalar el antivirus???
|
| PD. le hice un update a mi SO y el problema persiste.
| El antivirus lo he instalado en varios equipos con XP y
| es la primera vez que me pasa esto.
|
| Gracias por su ayuda
sylvia
2004-02-23 22:47:43 UTC
ya hice lo que me dices, y aparentemente el servicio esta
en inicio manual, pero luego le di clic en iniciar el
servicio y me marcó el sig error:

"No se puede inciar el servicio de Windows Installer en
el equipo local."

Posteriormente reinicie mi equipo en modo seguro y
ejecuté msiexec/regserver tal como me lo indicaste y me
marcó el sig. error:

"error 3: el sistema no puede hallar la ruta
especificada."

luego ejecute solo msiexec y me marcó el sig. error:
"Parametro de línea de comandos incorrectos."

la versión del windows installer de mi SO es
V2.00.2600.1106

que puedo hacer ahora, para solucionar este problema???

Gracias
-----Mensaje original-----
Panel de Control - Herramientas Administrativas -
Servicios
que el servicio "Windows Installer" esta en
Inicio "Manual".
Arranca en "modo seguro" (tecla F8 en el reinicio) y
Inicio - Ejecutar: msiexec /regserver
Reinicia el sistema.
--
Alejandro Curquejo
Microsoft MVP
Windows XP - Shell/User
---------------------------------------------------------
------------
*Este mensaje se proporciona "TAL COMO ESTA" sin
garantia de ninguna clase y
no otorga ningun derecho de reclamo*
*This posting is provided "AS IS" with no warranties,
and confers no rights*
---------------------------------------------------------
------------
-Tips y Articulos XP -
http://www.multingles.net/tutoriales.htm#ALE
-DTS-L.Org - http://www.dts-l.org/
---------------------------------------------------------
------------
Que es el Programa MVP (Most Valuable Professional)
http://mvp.support.microsoft.com/default.aspx?pr=mvpfaqs
---------------------------------------------------------
------------
| hola, tengo un equipo con SO XP professional, quiero
| instalar un antivirus, pero no me deja porque me marca
un
| error en el windows installer...este error dice que
| windows installer no esta bien instalado.
| que puedo hacer para que me deje instalar el
antivirus???
|
| PD. le hice un update a mi SO y el problema persiste.
| El antivirus lo he instalado en varios equipos con XP y
| es la primera vez que me pasa esto.
|
| Gracias por su ayuda
.
Alezito [MS MVP]
2004-02-24 01:32:10 UTC
Lo escribistes mal, es

msiexec /regserver

observa que entre la "c" y el "/" existe un espacio, intentalo de nuevo.
--
Alejandro Curquejo
Microsoft MVP
Windows XP - Shell/User
***@mvps.org
---------------------------------------------------------------------
*Este mensaje se proporciona "TAL COMO ESTA" sin garantia de ninguna clase y
no otorga ningun derecho de reclamo*
*This posting is provided "AS IS" with no warranties, and confers no rights*
---------------------------------------------------------------------
-Tips y Articulos XP - http://www.multingles.net/tutoriales.htm#ALE
-DTS-L.Org - http://www.dts-l.org/
---------------------------------------------------------------------
Que es el Programa MVP (Most Valuable Professional)
http://mvp.support.microsoft.com/default.aspx?pr=mvpfaqs
---------------------------------------------------------------------


"sylvia" <***@discussions.microsoft.com> escribi� en el mensaje news:006c01c3fa5f$0c626d00$***@phx.gbl...
ya hice lo que me dices, y aparentemente el servicio esta
en inicio manual, pero luego le di clic en iniciar el
servicio y me marcó el sig error:

"No se puede inciar el servicio de Windows Installer en
el equipo local."

Posteriormente reinicie mi equipo en modo seguro y
ejecuté msiexec/regserver tal como me lo indicaste y me
marcó el sig. error:

"error 3: el sistema no puede hallar la ruta
especificada."

luego ejecute solo msiexec y me marcó el sig. error:
"Parametro de línea de comandos incorrectos."

la versión del windows installer de mi SO es
V2.00.2600.1106

que puedo hacer ahora, para solucionar este problema???

Gracias
-----Mensaje original-----
Panel de Control - Herramientas Administrativas -
Servicios
que el servicio "Windows Installer" esta en
Inicio "Manual".
Arranca en "modo seguro" (tecla F8 en el reinicio) y
Inicio - Ejecutar: msiexec /regserver
Reinicia el sistema.
--
Alejandro Curquejo
Microsoft MVP
Windows XP - Shell/User
---------------------------------------------------------
------------
*Este mensaje se proporciona "TAL COMO ESTA" sin
garantia de ninguna clase y
no otorga ningun derecho de reclamo*
*This posting is provided "AS IS" with no warranties,
and confers no rights*
---------------------------------------------------------
------------
-Tips y Articulos XP -
http://www.multingles.net/tutoriales.htm#ALE
-DTS-L.Org - http://www.dts-l.org/
---------------------------------------------------------
------------
Que es el Programa MVP (Most Valuable Professional)
http://mvp.support.microsoft.com/default.aspx?pr=mvpfaqs
---------------------------------------------------------
------------
| hola, tengo un equipo con SO XP professional, quiero
| instalar un antivirus, pero no me deja porque me marca
un
| error en el windows installer...este error dice que
| windows installer no esta bien instalado.
| que puedo hacer para que me deje instalar el
antivirus???
|
| PD. le hice un update a mi SO y el problema persiste.
| El antivirus lo he instalado en varios equipos con XP y
| es la primera vez que me pasa esto.
|
| Gracias por su ayuda
.


Database (slave) 0.004063 s
44.2813 kB
Benchmark Min Max Average Total
SELECT `lang` FROM `newsgroup` WHERE `newsgroup_url` = 'microsoft.public.es.windowsxp' (4)
0.000184 s
0.000514 s
0.000351 s
0.001403 s
2.2344 kB
2.3672 kB
2.2676 kB
9.0703 kB
SELECT `code`, `name` FROM `lang` WHERE `code` = 'es' (3)
0.000159 s
0.000213 s
0.000179 s
0.000536 s
2.4141 kB
2.4141 kB
2.4141 kB
7.2422 kB
SELECT * FROM `lang` WHERE `code` = 'es' (1)
0.000219 s
0.000219 s
0.000219 s
0.000219 s
12.5313 kB
12.5313 kB
12.5313 kB
12.5313 kB
SELECT * FROM `thread` WHERE `hash` = 'ZDxWMch6' (1)
0.000482 s
0.000482 s
0.000482 s
0.000482 s
4.2500 kB
4.2500 kB
4.2500 kB
4.2500 kB
SELECT * FROM `newsgroup` WHERE `newsgroup_id` = '99130' (1)
0.000460 s
0.000460 s
0.000460 s
0.000460 s
5.8047 kB
5.8047 kB
5.8047 kB
5.8047 kB
SELECT * FROM `temp_simthread` WHERE `hash` = 'ZDxWMch6' (1)
0.000595 s
0.000595 s
0.000595 s
0.000595 s
2.6953 kB
2.6953 kB
2.6953 kB
2.6953 kB
SELECT text_res, img_res, manual FROM porndetect WHERE hash = 'ZDxWMch6' AND page = 1 (1)
0.000368 s
0.000368 s
0.000368 s
0.000368 s
2.6875 kB
2.6875 kB
2.6875 kB
2.6875 kB
Kohana 0.011918 s
46.7266 kB
Benchmark Min Max Average Total
find_file (69)
0.000016 s
0.000363 s
0.000173 s
0.011918 s
0.5234 kB
2.1563 kB
0.6772 kB
46.7266 kB
Requests 0.076366 s
475.1563 kB
Benchmark Min Max Average Total
"ZDxWMch6/reparar-windows-installer-en-xp" (1)
0.079488 s
0.079488 s
0.079488 s
0.079488 s
503.1563 kB
503.1563 kB
503.1563 kB
503.1563 kB
Thread controller 0.001555 s
27.7188 kB
Benchmark Min Max Average Total
Init (1)
0.001555 s
0.001555 s
0.001555 s
0.001555 s
27.7188 kB
27.7188 kB
27.7188 kB
27.7188 kB
Thread parsing 0.051896 s
116.0469 kB
Benchmark Min Max Average Total
Other (2)
0.000796 s
0.015001 s
0.007898 s
0.015797 s
14.4766 kB
30.4609 kB
22.4688 kB
44.9375 kB
PHP Post Parsing (1)
0.004519 s
0.004519 s
0.004519 s
0.004519 s
53.0000 kB
53.0000 kB
53.0000 kB
53.0000 kB
C++ Post Parsing (1)
0.031202 s
0.031202 s
0.031202 s
0.031202 s
12.2266 kB
12.2266 kB
12.2266 kB
12.2266 kB
Three (1)
0.000378 s
0.000378 s
0.000378 s
0.000378 s
5.8828 kB
5.8828 kB
5.8828 kB
5.8828 kB
Load & uncompress 0.000710 s
12.3047 kB
Benchmark Min Max Average Total
load_thread (1)
0.000710 s
0.000710 s
0.000710 s
0.000710 s
12.3047 kB
12.3047 kB
12.3047 kB
12.3047 kB
Application Execution (507) 0.020666 s 33.418700 s 0.197950 s 0.101128 s
749.6172 kB 4,534.3750 kB 1,358.4311 kB 1,125.3906 kB